System Requirements

Meet the system requirements

  1. Check your PHP version:

    php --version
    

    It must be higher than 5.3.5! Note: This means you cannot use the same version of PHP for testing that you might use to run a Drual 5 site.

PHP will also need to have the following libraries installed:

  1. Check for Java:

    java -version
    

    It doesn’t necessarily matter what version, but it will be required for Selenium.

  2. Directions are written to use commandline cURL. You can make sure it’s installed with:

    curl --version
    
  3. Selenium

Download the latest version of Selenium Server It’s under the heading Selenium Server (formerly the Selenium RC Server). This is a single file which can be placed any where you like on your system and run with the following command:

java -jar selenium-server-standalone-2.33.0.jar &
// replace with the name of the version you downloaded